Proofing (ClaroRead Pro only)

The optional Proofing feature in ClaroRead Pro lets you edit the scanned document before saving it, spell check, and train the OCR process for specialised vocabulary or fonts.

You can turn on Proofing by checking the "Proofread document before saving" checkbox on the Scan tab in Settings. Then scan as normal from scanner or PDF or image. After Preview the Proofing dialog will appear, accompanied by a Proofing spellcheck window:

The Proofing spellcheck lets to jump from error to error in the document. You can close this at any time and restart it from the Tools menu. See Proofreading.

In the centre of the window is the Text Editor. This shows any detected errors with a red underline, just like Microsoft Word. You can use this to correct spelling and recognition mistakes in your document. It always shows the page as in the format of the original so you can easily match up the text to the original document, but your Keep Original Format or Simplify Format setting will be preserved in the final output.

Above the Text Editor is the Verifier. This shows the actual original image you have scanner for where your caret is in the Text Editor. This lets you check the result of scanning (in the Text Editor) with the original image (in the Verifier window)

To the left is the Image Thumbnail View of all the pages in the document.

Use the Text Editor and Verifier to correct any OCR errors in your document, then click one of the buttons on the right to Send to Word or Save as File (as appropriate) when you are satisfied with the proofing.

Image Thumbnail View

The Image Thumbnail View shows all the pages in the document to be proofed. You can click on a page to select it. The Image Thumbnail View is not shown if your document only has one page. It also appears in the Preview view.

You can delete a page from the document by selecting it and pressing the Delete key (or right-clicking and selecting Clear from the popup context menu.

Status bar, Ruler and Toolbars

You can turn these on and off in the View menu. By default they are all off.

Views

You can view the current page in one of three ways, selected from the Text Editor views submenu of the View menu.

Verifier

In the Proofing stage you are working with what ClaroRead Pro thinks is the underlying page content. If you are scanning from a paper or an image file then this may be inaccurate - for example, you may have some damaged area of the paper that has confused ClaroRead. It might be hard to correct the text in the Proofing view if you don't have sight of the original image.

The Verifier provides you with a view of the underlying image or paper that ClaroRead is processing. This lets you check the text you have got (in the Text Editor) against what was on the original page (in the Verifier). Just turn it on in the View menu (Verifier submenu, select Show) and click anywhere in the Text Editor text. The Verifier then shows the original page at that point so you can check they match. You can zoom this original view in and out to check smaller details with the Zoom submenu.

By default the Verifier is shown at the top of the Text Editor. To make it float (follow the cursor) select Dynamic. To change what is shown in the floating Verifier select Line, Three words or One word from the Verifier submenu.

Character Map

You may have non-standard characters for your current language in your text. For example, in a maths textbook you will often have Greek characters like sigma (Σ) or pi (Π). This may confuse ClaroRead (if it is scanning English it will try to fit every letter into an English character, for example) and produce wrong results. You can solve this and improve scanning by adding these non-standard characters to the set of recognised characters by using the Character Map. Make the character set you want to use visible by selecting it in View, Character Map, Character sets. Then click on the characters to add to the recognised set of characters for your scanning. These will be used in subsequent scans and remembered, so you only have to do this once. The characters you select will be added to the document, so simply delete them.

You can also select "Edit permitted characters" in the Tools menu and add characters you want to be recognised by hand.

Character Training

You may want to correct some sections of text which have been incorrectly identified, like Greek letters used in maths or scanned text from paper. These characters or sections will be highlighted in yellow in the Text Editor. Click on the character to place the caret on it. Then select "Train character recognition" from the Tools menu. The "Train Character" window will open, showing the original text/image and what ClaroRead thinks it is. Enter the correct character or characters in the "Correct" box and click Train to correct the scanned text. These corrections will be remembered for next time.

You can review the character training by selecting "Edit character training" from the Tools menu. Select and delete any training you do not want to be saved, or right-click and edit it.

You may need to train several characters, for example where ClaroRead has incorrectly identified a single letter as several letters. Simply select all the affected letters before you click "Train character recognition" and the training and correction will be applied to all the letters.

Format

You can edit the text in the Proofing dialog, and the Format menu lets you change font, paragraph alignment, style and other text attributes. This is useful if you are planning to save the document as a PDF file and want to amend how it will look, for example using a more readable font to replace what has been used in the original scanned document. However, if you are sending the document to Word to read or edit you will probably find this easier to do there.

Note that if you are saving as PDF the original position and size of text areas will be retained. So if you make text bigger it will start to overlap and bits will be missing. If you want to edit the document you are scanning we suggest sending it to Microsoft Word to edit and correct it, rather than using the Proofing dialogue.

Proofreading

Just like Microsoft Word, the Proofing dialog will take you through all the identified spelling or OCR errors in the current document. This starts automatically when you open the Proofread dialog. You can also select Proofread from the Tools menu and the Proofreading process will re-start. You will be shown the next spelling or OCR problem and can decide whether to correct or add it, just like the spell check in Word. Changes will be remembered for future scanning sessions. When you have finished with a page or document click the Page Ready or Document Ready button and no more errors on this page will be identified. When there are no more errors in the document then the Proofread option will grey out.

You can also press F4 or select "Find next suspect" to jump straight to the next identified error in the page without opening the Proofreading process. If you want to start the Proofing process again, having previously marked pages or the whole document as done, then select Recheck Page from the Tools menu.

You can review the spellings you have added to the Proofing dictionary by selecting "Edit user dictionary" from the Tools menu. This will show a list of the words that will be recognised as correct spellings. You can delete any words that should not be there and should be marked as incorrectly-spelled.

Language

It is vital that ClaroRead has the language of the document correct, or it will not recognise (OCR) correctly and it will identify all the words as incorrectly-spelled. The Status Bar will show the language of the current text (where the caret is positioned). You can select text and identify the correct language by selecting the language from the Tools menu.